$re = '/JOB[\s\w-:]+#(?<job>\w+)\[.+[\s\w=]+\:\s?(?<user>[^\s]+)[\s\w=]+\:\s?(?<script>[^\s]+)[\s\w=]+\:\s?(?<job_number>[^\s]+)[\s\S]+Exit\sStatus\s+\:(?<exit_status>\w+)/m';
$str = '================================================================
= JOB : MAXFED33S-LHMX#MDK1997DAILYFTPCONN[(2130 10/31/18),(0AAAAAAAAAAAOBWS)]
= USER : DOMAIN\\khectic
= SCRIPT : c:\\scripts\\mdk_copy.bat
= Job Number: 2484514
===============================================================
********************************************************************************************
** copying from
** \\temp\\mdk_temp.csv
** to
** \\target\\
** success **
********************************************************************************************
===============================================================
= Exit Status :OK
===============================================================';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);