import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "JOB[\\s\\w-:]+#(?<job>\\w+)\\[.+[\\s\\w=]+\\:\\s?(?<user>[^\\s]+)[\\s\\w=]+\\:\\s?(?<script>[^\\s]+)[\\s\\w=]+\\:\\s?(?<job_number>[^\\s]+)[\\s\\S]+Exit\\sStatus\\s+\\:(?<exit_status>\\w+)";
final String string = "================================================================\n"
+ " = JOB : MAXFED33S-LHMX#MDK1997DAILYFTPCONN[(2130 10/31/18),(0AAAAAAAAAAAOBWS)] \n"
+ " = USER : DOMAIN\\khectic \n"
+ " = SCRIPT : c:\\scripts\\mdk_copy.bat \n"
+ " = Job Number: 2484514 \n"
+ " =============================================================== \n"
+ " ******************************************************************************************** \n"
+ " ** copying from \n"
+ " ** \\temp\\mdk_temp.csv \n"
+ " ** to \n"
+ " ** \\target\\ \n"
+ " ** success ** \n"
+ " ******************************************************************************************** \n"
+ " =============================================================== \n"
+ " = Exit Status :OK \n"
+ " ===============================================================";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}