const regex = /JOB[\s\w-:]+#(?<job>\w+)\[.+[\s\w=]+\:\s?(?<user>[^\s]+)[\s\w=]+\:\s?(?<script>[^\s]+)[\s\w=]+\:\s?(?<job_number>[^\s]+)[\s\S]+Exit\sStatus\s+\:(?<exit_status>\w+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('JOB[\\s\\w-:]+#(?<job>\\w+)\\[.+[\\s\\w=]+\\:\\s?(?<user>[^\\s]+)[\\s\\w=]+\\:\\s?(?<script>[^\\s]+)[\\s\\w=]+\\:\\s?(?<job_number>[^\\s]+)[\\s\\S]+Exit\\sStatus\\s+\\:(?<exit_status>\\w+)', 'gm')
const str = `================================================================
= JOB : MAXFED33S-LHMX#MDK1997DAILYFTPCONN[(2130 10/31/18),(0AAAAAAAAAAAOBWS)]
= USER : DOMAIN\\khectic
= SCRIPT : c:\\scripts\\mdk_copy.bat
= Job Number: 2484514
===============================================================
********************************************************************************************
** copying from
** \\temp\\mdk_temp.csv
** to
** \\target\\
** success **
********************************************************************************************
===============================================================
= Exit Status :OK
===============================================================`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}