re = /JOB[\s\w-:]+#(?<job>\w+)\[.+[\s\w=]+\:\s?(?<user>[^\s]+)[\s\w=]+\:\s?(?<script>[^\s]+)[\s\w=]+\:\s?(?<job_number>[^\s]+)[\s\S]+Exit\sStatus\s+\:(?<exit_status>\w+)/m
str = '================================================================
= JOB : MAXFED33S-LHMX#MDK1997DAILYFTPCONN[(2130 10/31/18),(0AAAAAAAAAAAOBWS)]
= USER : DOMAIN\\khectic
= SCRIPT : c:\\scripts\\mdk_copy.bat
= Job Number: 2484514
===============================================================
********************************************************************************************
** copying from
** \\temp\\mdk_temp.csv
** to
** \\target\\
** success **
********************************************************************************************
===============================================================
= Exit Status :OK
==============================================================='
# Print the match result
str.scan(re) do |match|
puts match.to_s
end