#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\w).*?\1"
Local $sString = "Outdoors" & @CRLF & _
"dog" & @CRLF & _
"step" & @CRLF & _
"bee" & @CRLF & _
"Chessboard" & @CRLF & _
"Cookbooks" & @CRLF & _
"Professionally" & @CRLF & _
"Attractiveness" & @CRLF & _
"Uncontrollably" & @CRLF & _
"disreputably" & @CRLF & _
"Recommendation" & @CRLF & _
"Interrogations" & @CRLF & _
"Aggressiveness" & @CRLF & _
"doublethinks" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")