$re = '/(\w).*?\1/';
$str = 'Outdoors
dog
step
bee
Chessboard
Cookbooks
Professionally
Attractiveness
Uncontrollably
disreputably
Recommendation
Interrogations
Aggressiveness
doublethinks
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);