re = /(\w).*?\1/
str = 'Outdoors
dog
step
bee
Chessboard
Cookbooks
Professionally
Attractiveness
Uncontrollably
disreputably
Recommendation
Interrogations
Aggressiveness
doublethinks
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end