import re
regex = re.compile(r"(\w).*?\1")
test_str = ("Outdoors\n"
"dog\n"
"step\n"
"bee\n"
"Chessboard\n"
"Cookbooks\n"
"Professionally\n"
"Attractiveness\n"
"Uncontrollably\n"
"disreputably\n"
"Recommendation\n"
"Interrogations\n"
"Aggressiveness\n"
"doublethinks\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")