import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w).*?\\1";
final String string = "Outdoors\n"
+ "dog\n"
+ "step\n"
+ "bee\n"
+ "Chessboard\n"
+ "Cookbooks\n"
+ "Professionally\n"
+ "Attractiveness\n"
+ "Uncontrollably\n"
+ "disreputably\n"
+ "Recommendation\n"
+ "Interrogations\n"
+ "Aggressiveness\n"
+ "doublethinks\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}