#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)https?://(?|j\.gifs\.com/([^ /\n]+)\.gif|gifs\.com/gif/([^ /\n]+))"
Local $sString = "https://gifs.com/gif/gJyM5j" & @CRLF & _
"https://j.gifs.com/gJyM5j.gif"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")