import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?://(?|j\\.gifs\\.com/([^ /\\n]+)\\.gif|gifs\\.com/gif/([^ /\\n]+))";
final String string = "https://gifs.com/gif/gJyM5j\n"
+ "https://j.gifs.com/gJyM5j.gif";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}