package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)https?://(?|j\.gifs\.com/([^ /\n]+)\.gif|gifs\.com/gif/([^ /\n]+))`)
var str = `https://gifs.com/gif/gJyM5j
https://j.gifs.com/gJyM5j.gif`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}