const regex = new RegExp('https?://(?|j\\.gifs\\.com/([^ /\\n]+)\\.gif|gifs\\.com/gif/([^ /\\n]+))', 'ig')
const str = `https://gifs.com/gif/gJyM5j
https://j.gifs.com/gJyM5j.gif`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}