#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=\S*[A-Z])(?=\S*\d)[A-Z0-9-]{4,10}.*\d+,\d{2}"
Local $sString = "LL123LL [Mixed Data and Numbers] 1.650,00" & @CRLF & _
"123456-L12 [Mixed Data and Numbers] 49,00" & @CRLF & _
"LL123L [Mixed Data and Numbers] 208,00" & @CRLF & _
"LL123LLL [Mixed Data and Numbers] 3,00" & @CRLF & _
"" & @CRLF & _
"Not to match:" & @CRLF & _
"LLLL [Mixed Data and Numbers] 1.650,00" & @CRLF & _
"L-LLL [Mixed Data and Numbers] 1.650,00" & @CRLF & _
"1223-4 [Mixed Data and Numbers] 1.650,00" & @CRLF & _
"12234 [Mixed Data and Numbers] 1.650,00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")