const regex = new RegExp('^(?=\\S*[A-Z])(?=\\S*\\d)[A-Z0-9-]{4,10}.*\\d+,\\d{2}', 'gm')
const str = `LL123LL [Mixed Data and Numbers] 1.650,00
123456-L12 [Mixed Data and Numbers] 49,00
LL123L [Mixed Data and Numbers] 208,00
LL123LLL [Mixed Data and Numbers] 3,00
Not to match:
LLLL [Mixed Data and Numbers] 1.650,00
L-LLL [Mixed Data and Numbers] 1.650,00
1223-4 [Mixed Data and Numbers] 1.650,00
12234 [Mixed Data and Numbers] 1.650,00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}