use strict;
my $str = 'LL123LL [Mixed Data and Numbers] 1.650,00
123456-L12 [Mixed Data and Numbers] 49,00
LL123L [Mixed Data and Numbers] 208,00
LL123LLL [Mixed Data and Numbers] 3,00
Not to match:
LLLL [Mixed Data and Numbers] 1.650,00
L-LLL [Mixed Data and Numbers] 1.650,00
1223-4 [Mixed Data and Numbers] 1.650,00
12234 [Mixed Data and Numbers] 1.650,00';
my $regex = qr/^(?=\S*[A-Z])(?=\S*\d)[A-Z0-9-]{4,10}.*\d+,\d{2}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}