import Foundation
let pattern = #"^(?=\S*[A-Z])(?=\S*\d)[A-Z0-9-]{4,10}.*\d+,\d{2}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
LL123LL [Mixed Data and Numbers] 1.650,00
123456-L12 [Mixed Data and Numbers] 49,00
LL123L [Mixed Data and Numbers] 208,00
LL123LLL [Mixed Data and Numbers] 3,00
Not to match:
LLLL [Mixed Data and Numbers] 1.650,00
L-LLL [Mixed Data and Numbers] 1.650,00
1223-4 [Mixed Data and Numbers] 1.650,00
12234 [Mixed Data and Numbers] 1.650,00
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)