re = /^(?=\S*[A-Z])(?=\S*\d)[A-Z0-9-]{4,10}.*\d+,\d{2}/m
str = 'LL123LL [Mixed Data and Numbers] 1.650,00
123456-L12 [Mixed Data and Numbers] 49,00
LL123L [Mixed Data and Numbers] 208,00
LL123LLL [Mixed Data and Numbers] 3,00
Not to match:
LLLL [Mixed Data and Numbers] 1.650,00
L-LLL [Mixed Data and Numbers] 1.650,00
1223-4 [Mixed Data and Numbers] 1.650,00
12234 [Mixed Data and Numbers] 1.650,00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end