# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?=\S*[A-Z])(?=\S*\d)[A-Z0-9-]{4,10}.*\d+,\d{2}"
test_str = ("LL123LL [Mixed Data and Numbers] 1.650,00\n"
"123456-L12 [Mixed Data and Numbers] 49,00\n"
"LL123L [Mixed Data and Numbers] 208,00\n"
"LL123LLL [Mixed Data and Numbers] 3,00\n\n"
"Not to match:\n"
"LLLL [Mixed Data and Numbers] 1.650,00\n"
"L-LLL [Mixed Data and Numbers] 1.650,00\n"
"1223-4 [Mixed Data and Numbers] 1.650,00\n"
"12234 [Mixed Data and Numbers] 1.650,00")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.