#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(http:\/\/[a-zA-Z.-_]{1,}){1}[">.a-zA-Z<>\/]{1,}\nStatic text\n[">.a-zA-Z<>\/ =]{1,}(http:\/\/[a-zA-Z.-_]{1,}){1,}"
Local $sString = "<a href="http://google.com">google.com</a>" & @CRLF & _
"Static text" & @CRLF & _
"<a href="http://Bing.com">bing.com</a>" & @CRLF & _
"<a href="http://google.com">google.com</a>" & @CRLF & _
"Static text" & @CRLF & _
"<a href="http://Bing.com">bing.com</a>" & @CRLF & _
"<a href="http://Bing.com">bing.com</a>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")