$re = '/(http:\/\/[a-zA-Z.-_]{1,}){1}[">.a-zA-Z<>\/]{1,}\nStatic text\n[">.a-zA-Z<>\/ =]{1,}(http:\/\/[a-zA-Z.-_]{1,}){1,}/s';
$str = '<a href="http://google.com">google.com</a>
Static text
<a href="http://Bing.com">bing.com</a>
<a href="http://google.com">google.com</a>
Static text
<a href="http://Bing.com">bing.com</a>
<a href="http://Bing.com">bing.com</a>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);