using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http:\/\/[a-zA-Z.-_]{1,}){1}["">.a-zA-Z<>\/]{1,}\nStatic text\n["">.a-zA-Z<>\/ =]{1,}(http:\/\/[a-zA-Z.-_]{1,}){1,}";
string input = @"<a href=""http://google.com"">google.com</a>
Static text
<a href=""http://Bing.com"">bing.com</a>
<a href=""http://google.com"">google.com</a>
Static text
<a href=""http://Bing.com"">bing.com</a>
<a href=""http://Bing.com"">bing.com</a>
";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}