const regex = /(http:\/\/[a-zA-Z.-_]{1,}){1}[">.a-zA-Z<>\/]{1,}\nStatic text\n[">.a-zA-Z<>\/ =]{1,}(http:\/\/[a-zA-Z.-_]{1,}){1,}/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(http:\\\/\\\/[a-zA-Z.-_]{1,}){1}[">.a-zA-Z<>\\\/]{1,}\\nStatic text\\n[">.a-zA-Z<>\\\/ =]{1,}(http:\\\/\\\/[a-zA-Z.-_]{1,}){1,}', 'gs')
const str = `<a href="http://google.com">google.com</a>
Static text
<a href="http://Bing.com">bing.com</a>
<a href="http://google.com">google.com</a>
Static text
<a href="http://Bing.com">bing.com</a>
<a href="http://Bing.com">bing.com</a>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}