// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s)(http:\/\/[a-zA-Z.-_]{1,}){1}[">.a-zA-Z<>\/]{1,}\nStatic text\n[">.a-zA-Z<>\/ =]{1,}(http:\/\/[a-zA-Z.-_]{1,}){1,}"#).unwrap();
let string = "<a href=\"http://google.com\">google.com</a>
Static text
<a href=\"http://Bing.com\">bing.com</a>
<a href=\"http://google.com\">google.com</a>
Static text
<a href=\"http://Bing.com\">bing.com</a>
<a href=\"http://Bing.com\">bing.com</a>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}