import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http:\\/\\/[a-zA-Z.-_]{1,}){1}[\">.a-zA-Z<>\\/]{1,}\\nStatic text\\n[\">.a-zA-Z<>\\/ =]{1,}(http:\\/\\/[a-zA-Z.-_]{1,}){1,}";
final String string = "<a href=\"http://google.com\">google.com</a>\n"
+ "Static text\n"
+ "<a href=\"http://Bing.com\">bing.com</a>\n"
+ "<a href=\"http://google.com\">google.com</a>\n"
+ "Static text\n"
+ "<a href=\"http://Bing.com\">bing.com</a>\n"
+ "<a href=\"http://Bing.com\">bing.com</a>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}