#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(?(DEFINE)(?<measure>" & @CRLF & _
" (?:\d+ \s*)? \d+ / \d+ (?:in|")" & @CRLF & _
"))" & @CRLF & _
"" & @CRLF & _
"(?&measure) \s* x \s* (?&measure) (*SKIP)(*FAIL)" & @CRLF & _
"| (?&measure)"
Local $sString = "A product description with 12 1/2" in it." & @CRLF & _
"Product description with 19 3/4" x 19 5/8" in it."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")