import Foundation
let pattern = #"""
(?(DEFINE)(?<measure>
(?:\d+ \s*)? \d+ / \d+ (?:in|")
))
(?&measure) \s* x \s* (?&measure) (*SKIP)(*FAIL)
| (?&measure)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"""
A product description with 12 1/2" in it.
Product description with 19 3/4" x 19 5/8" in it.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)