// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?x)(?(DEFINE)(?<measure>
(?:\d+ \s*)? \d+ / \d+ (?:in|")
))
(?&measure) \s* x \s* (?&measure) (*SKIP)(*FAIL)
| (?&measure)"#).unwrap();
let string = "A product description with 12 1/2\" in it.
Product description with 19 3/4\" x 19 5/8\" in it.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}