package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?(DEFINE)(?<measure>
(?:\d+ \s*)? \d+ / \d+ (?:in|")
))
(?&measure) \s* x \s* (?&measure) (*SKIP)(*FAIL)
| (?&measure)`)
var str = `A product description with 12 1/2" in it.
Product description with 19 3/4" x 19 5/8" in it.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}