$re = '@(?(DEFINE)(?<measure>
(?:\d+ \s*)? \d+ / \d+ (?:in|")
))
(?&measure) \s* x \s* (?&measure) (*SKIP)(*FAIL)
| (?&measure)@x';
$str = 'A product description with 12 1/2" in it.
Product description with 19 3/4" x 19 5/8" in it.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);