using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?(DEFINE)(?<measure>
(?:\d+ \s*)? \d+ / \d+ (?:in|"")
))
(?&measure) \s* x \s* (?&measure) (*SKIP)(*FAIL)
| (?&measure)";
string input = @"A product description with 12 1/2"" in it.
Product description with 19 3/4"" x 19 5/8"" in it.";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}