#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.*\.)?somedomain\.com:8000([\/?#&].*)custom.css$"
Local $sString = "https://somedomain.com:8000/s/asdfsadfsadf/asdfsdfsad/custom.css" & @CRLF & _
"http://somedomain.com:8000/s/asdfsadfsadf/asdfsdfsad/custom.css" & @CRLF & _
"http://somedomain.com:8000/s/asdfsadfsadf/asdfsdfsad/hello.html" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")