package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*\.)?somedomain\.com:8000([\/?#&].*)custom.css$`)
var str = `https://somedomain.com:8000/s/asdfsadfsadf/asdfsdfsad/custom.css
http://somedomain.com:8000/s/asdfsadfsadf/asdfsdfsad/custom.css
http://somedomain.com:8000/s/asdfsadfsadf/asdfsdfsad/hello.html
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}