const regex = /(.*\.)?somedomain\.com:8000([\/?#&].*)custom.css$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*\\.)?somedomain\\.com:8000([\\\/?#&].*)custom.css$', 'gm')
const str = `https://somedomain.com:8000/s/asdfsadfsadf/asdfsdfsad/custom.css
http://somedomain.com:8000/s/asdfsadfsadf/asdfsdfsad/custom.css
http://somedomain.com:8000/s/asdfsadfsadf/asdfsdfsad/hello.html
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}