using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*\.)?somedomain\.com:8000([\/?#&].*)custom.css$";
string input = @"https://somedomain.com:8000/s/asdfsadfsadf/asdfsdfsad/custom.css
http://somedomain.com:8000/s/asdfsadfsadf/asdfsdfsad/custom.css
http://somedomain.com:8000/s/asdfsadfsadf/asdfsdfsad/hello.html
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}