$re = '/(.*\.)?somedomain\.com:8000([\/?#&].*)custom.css$/m';
$str = 'https://somedomain.com:8000/s/asdfsadfsadf/asdfsdfsad/custom.css
http://somedomain.com:8000/s/asdfsadfsadf/asdfsdfsad/custom.css
http://somedomain.com:8000/s/asdfsadfsadf/asdfsdfsad/hello.html
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);