import Foundation
let pattern = ##"(.*\.)?somedomain\.com:8000([\/?#&].*)custom.css$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://somedomain.com:8000/s/asdfsadfsadf/asdfsdfsad/custom.css
http://somedomain.com:8000/s/asdfsadfsadf/asdfsdfsad/custom.css
http://somedomain.com:8000/s/asdfsadfsadf/asdfsdfsad/hello.html
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)