using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" [\s,]* # any spaces or commas (or nothing)
\# # hash character
([^#,]+) # the tag (anything but hash or comma)
(?!\s*,,[\s#,]*)
[\s#,]* # any spaces, #, or commas (or nothing)
$ # end of text";
string input = @"#case, with added #de description,, #and, #some #tägs
#case, with added #de description,, #and
#case, with added #de description,,
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}