const regex = new RegExp(' [\\s,]* # any spaces or commas (or nothing)
\\# # hash character
([^#,]+) # the tag (anything but hash or comma)
(?!\\s*,,[\\s#,]*)
[\\s#,]* # any spaces, #, or commas (or nothing)
$ # end of text', 'gm')
const str = `#case, with added #de description,, #and, #some #tägs
#case, with added #de description,, #and
#case, with added #de description,,
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}