$re = '/ [\s,]* # any spaces or commas (or nothing)
\# # hash character
([^#,]+) # the tag (anything but hash or comma)
(?!\s*,,[\s#,]*)
[\s#,]* # any spaces, #, or commas (or nothing)
$ # end of text/mx';
$str = '#case, with added #de description,, #and, #some #tägs
#case, with added #de description,, #and
#case, with added #de description,,
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);