use strict;
my $str = '#case, with added #de description,, #and, #some #tägs
#case, with added #de description,, #and
#case, with added #de description,,
';
my $regex = qr/ [\s,]* # any spaces or commas (or nothing)
\# # hash character
([^#,]+) # the tag (anything but hash or comma)
(?!\s*,,[\s#,]*)
[\s#,]* # any spaces, #, or commas (or nothing)
$ # end of text/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}