// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx) [\s,]* # any spaces or commas (or nothing)
\# # hash character
([^#,]+) # the tag (anything but hash or comma)
(?!\s*,,[\s#,]*)
[\s#,]* # any spaces, #, or commas (or nothing)
$ # end of text").unwrap();
let string = "#case, with added #de description,, #and, #some #tägs
#case, with added #de description,, #and
#case, with added #de description,,
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}