re = / [\s,]* # any spaces or commas (or nothing)
\# # hash character
([^#,]+) # the tag (anything but hash or comma)
(?!\s*,,[\s#,]*)
[\s#,]* # any spaces, #, or commas (or nothing)
$ # end of text/mx
str = '#case, with added #de description,, #and, #some #tägs
#case, with added #de description,, #and
#case, with added #de description,,
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end