#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^field\d+:.*(?:\r?\n(?!field\d+:).*)*"
Local $sString = "field1: content asd.." & @CRLF & _
"" & @CRLF & _
"field2: content" & @CRLF & _
"" & @CRLF & _
"qwe..." & @CRLF & _
"" & @CRLF & _
"field3: content asfdqegt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")