import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^field\\d+:.*(?:\\r?\\n(?!field\\d+:).*)*";
final String string = "field1: content asd..\n\n"
+ "field2: content\n\n"
+ "qwe...\n\n"
+ "field3: content asfdqegt";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}