re = /^field\d+:.*(?:\r?\n(?!field\d+:).*)*/m
str = 'field1: content asd..
field2: content
qwe...
field3: content asfdqegt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end