using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^field\d+:.*(?:\r?\n(?!field\d+:).*)*";
string input = @"field1: content asd..
field2: content
qwe...
field3: content asfdqegt";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}