$re = '/^field\d+:.*(?:\r?\n(?!field\d+:).*)*/m';
$str = 'field1: content asd..
field2: content
qwe...
field3: content asfdqegt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);