const regex = new RegExp('^field\\d+:.*(?:\\r?\\n(?!field\\d+:).*)*', 'gm')
const str = `field1: content asd..
field2: content
qwe...
field3: content asfdqegt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}