#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\s*)"
Local $sString = "<!DOCTYPE html>" & @CRLF & _
"<html>" & @CRLF & _
" <head></head>" & @CRLF & _
" <body>" & @CRLF & _
" <h1>My Site</h1>" & @CRLF & _
" <div id="block1">" & @CRLF & _
" <p>Hello, friend!</p>" & @CRLF & _
" <p>Read it:</p>" & @CRLF & _
" <ul>" & @CRLF & _
" <li>Item 1</li>" & @CRLF & _
" <li>Item 2</li>" & @CRLF & _
" <li>Item 3</li>" & @CRLF & _
" </ul>" & @CRLF & _
" </div>" & @CRLF & _
" </body>" & @CRLF & _
"</html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")